The Adobe Flash player is required.